Don't forget to check "Static content service" in IIS7 installation

Before a couple of days ,I started to work on Vista and IIS 7, and since the default installation for Vista doesn't includes IIS7 ,

I started by trying to  install IIS 7.So I went to control panel, Programs and features, then to " turns windows features on or off",

After the dialog displayed , I navigate to application development features and checked asp.net and IIS management console,

then I selected to install them , after the installation finishes , I prompted to restart the computer and i did.

after i logged in a gain , and after i added an existing website to in IIS, i requested the website from the browser,then the problems started ,

the browser displayed an empty page with no images , no scripts ... I tried to restart, reinstall with no luck , after many  hours I find it , 

I didn't checked the "Static Content service" , look at the red Box in the Image below :

Note that the "static content" service is responsible for serving the Static contents like images, scripts , style sheets file, ....

In my opinion , if the user doesn't checked this option( which will be checked by default if you checked the " internet information service " root node  ) windows vista must displays an alert or something , so that the user  doesn't waste the time to know the problem ...

I have posted this problem  and hoping to help some one in the future.

BTW: this problem still exists in windows 7 and window server 2008

 

Best Regards,

Anas Ghanem 

Published Friday, May 23, 2008 10:31 PM by anas
Filed under: ,

Comments

# re: Don't forget to check "Static content service" in IIS7 installation

Monday, November 3, 2008 5:20 AM by Henke

Thanks!

It solved my problems...MS really should warn the user if static content is not chosen!

# re: Don't forget to check "Static content service" in IIS7 installation

Wednesday, February 11, 2009 12:48 AM by John

Thank God for google and your random blog post. Just spent an hour tearing my hair out trying to figure out what I did wrong while I was setting up PHP!

# re: Don't forget to check "Static content service" in IIS7 installation

Tuesday, April 7, 2009 1:48 PM by Rob

Thanks, I have been trying to solve this problem for a couple of days.

# re: Don't forget to check "Static content service" in IIS7 installation

Thursday, June 11, 2009 2:09 PM by Scott

Thanks for posting.  This solved my issue as well.

# re: Don't forget to check "Static content service" in IIS7 installation

Saturday, August 22, 2009 12:17 AM by Tucker

You are the man! Thanks

# re: Don't forget to check "Static content service" in IIS7 installation

Monday, September 14, 2009 11:37 AM by Stephan

Thank you for ending my nightmare.

# re: Don't forget to check "Static content service" in IIS7 installation

Monday, January 18, 2010 4:31 AM by Dnx

Thanks, u help me saving a lot of time and headache!

;)

# re: Don't forget to check "Static content service" in IIS7 installation

Thursday, July 29, 2010 8:49 AM by Jin

Hi Man, you're really something, thank you for the post, it is really helpful.

# re: Don't forget to check "Static content service" in IIS7 installation

Sunday, January 9, 2011 7:19 PM by Wieslaw

Thanks for help, I have spen few houers to investigate this :(.

# re: Don't forget to check "Static content service" in IIS7 installation

Monday, February 21, 2011 9:24 PM by nvantas

Windows Server 2008 and IIS 7.5 really bites the big one!

This sucks!

Static content IS frigging checked, but still cannot access a simple One-Click deployed application that works with every other frigging MS OS!

What is wrong with those Redmond idiots!!!  Too much rain and cold air, and perhaps too many trips to pot-loving Vancouver!

# re: Don't forget to check "Static content service" in IIS7 installation

Tuesday, March 8, 2011 4:36 AM by nabeelfaruqui

thanks a lot. that saved much of our time. Its a really great and useful post.

I am very thankful to you

Thanks and Regards

Nabeel Faruqui

# re: Don't forget to check "Static content service" in IIS7 installation

Tuesday, March 8, 2011 4:37 AM by nabeelfaruqui

Thanks a lot man  !

saved much of our valuable time

Thanks and Regards

# re: Don't forget to check "Static content service" in IIS7 installation

Tuesday, May 24, 2011 9:22 PM by weblogs.asp.net

Don t forget to check quot static content service quot in iis7 installation.. Ho-o-o-o-t :)

# re: Don't forget to check "Static content service" in IIS7 installation

Tuesday, September 6, 2011 4:41 PM by Joe

Does anyone know where this "Enable Static Content" feature can be enabled:

1) on WinServer2008 R2

2) after IIS was already installed?

Thanks,

Joe

# re: Don't forget to check "Static content service" in IIS7 installation

Tuesday, September 20, 2011 5:07 AM by Andy

@Joe - yes, it's under Server Manager > Roles > Add Role Services.  You need to check the box next to Static Content

# re: Don't forget to check "Static content service" in IIS7 installation

Thursday, October 27, 2011 6:56 AM by rudraksha

It does not help my problem.

# re: Don't forget to check "Static content service" in IIS7 installation

Friday, December 2, 2011 8:19 AM by Berserker

Thanks, you made my day!

# re: Don't forget to check "Static content service" in IIS7 installation

Wednesday, August 22, 2012 3:41 PM by Rick

thanks, worked like a charm.

# re: Don't forget to check "Static content service" in IIS7 installation

Monday, October 8, 2012 4:18 PM by harry

Jeez, I hv been lookin for a solution to this since morning,my head has bin spinning almst gave up,tnx man,u r freakin awesome