Here's one that some of you may have seen before, but I thought I'd post it to save some time to those who didn't.
Today we were trying to debug some client-side code and we needed to quickly wire the click event of a button. So we did this, without thinking too hard:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
So the valuable lesson we've learned here is to adopt a naming convention for our event handlers that can't conflict with the name of the event. I usually choose elementIdOnEventName. For example here if the input's id is button1, we'd go with button1OnClick.