WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

--  2/25/2007: Added user driven carousel movement to the albums  --

Back in December I released a sample application that demonstrated how WPF/E and ASP.NET AJAX could be integrated to view albums returned from an Amazon.com Web Service in a simulated 3D type view. I finally made some time to get the application running live on my site so feel free to try it out if you get a chance.  If you find issues/bugs please add a comment and I'll try to make any necessary changes (include any details such as OS and browser....and keep in mind that WPF/E is still in CTP mode at this point).  Not all artists seem to be available from the Web Service unfortunately.

Run the AlbumViewer Application

 

A video that discusses the fundamentals of using WPF/E and ASP.NET AJAX to build the Album Viewer application can be viewed here.

 

Published Friday, February 23, 2007 11:57 PM by dwahlin

Comments

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 8:14 AM by Mark Wisecarver

Peter Gabriel ran fine, couldn't find Cat Power and Ted Nugent bombed out IE7 with a fatal error, (on XP Pro SP 2 running the latest WinFX):

Unhandled exception at 0x0c948fcf in iexplore.exe: 0xC0000005: Access violation reading location 0x00000000.

Other than that...It's spiffy!

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 9:08 AM by cnsbradford

Dan, I'm getting a "_LoadingCanvas" javascript error when viewing it.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 11:47 AM by dwahlin

Thanks for posting those issues.  The _LoadingCanvas error sounds like a timing issue...I'm not able to duplicate that one on Vista or XP.  The access violation error doesn't occur on my Vista machine but I was able to duplicate it on XP Pro.  It's caused by a bad image from the Web Service being returned (image doesn't exist for example) and WPF/E isn't handling that very gracefully in this release.  But, I'll see if I can trap it somehow.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 1:51 PM by Mark Wisecarver

U da man Dan.

Thanks a bunch bro.

As a big fan of Microsoft, and a long-time developer, I'm eagerly looking forward to running Vista Ultimate, soon. I attended a release event in N.C. last week, very impressive to say the least.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 3:19 PM by dwahlin

I upgraded the code to use the newest Amazon.com Web Service and that seems to have fixed several issues with particular artists not showing up and bad images being returned (that WPF/E doesn't handle real gracefully currently).  Let me know if you find other issues though.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 3:25 PM by dwahlin

No problem.  I have to say that I really do like Vista.  I've had a few minor issues, but they've all been fixed with service releases.  Overall things seem to run faster and I like how things are organized and displayed.

By the way, Cat Power now works as well as Ted. :-)

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 6:07 PM by Mark Wisecarver

Tested again just now on the same system, worked perfectly, awesome, simply awesome.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 6:54 PM by dwahlin

Great!  Thanks for testing it again Mark.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live

Saturday, February 24, 2007 8:32 PM by dwahlin

Thanks Chad.  I'll definitely consider those types of things for future enhancements. A lot of the behavior in there now was put in due to limitations encountered with the earlier builds of WPF/E.  I need to re-visit some of the things though to see if they've been fixed.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

Sunday, February 25, 2007 7:34 PM by Mark Wisecarver

You've got me hooked Dan, that carousel feature is more than I would have expected from WPF.

I'm planning on using this sort of thing for on-line cartoons, this will definitely bring a new twist to an old thing.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

Tuesday, February 27, 2007 4:01 PM by brady gaster

Supersweet, Dan! Amazing stuff as usual!

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

Tuesday, February 27, 2007 4:06 PM by Stuart

Search for "Dave Matthews Band"

Then rotate the albums, look at the points where albums overlap at the sides, some are showing up incorrectly. i.e albums in the back are showing over albums in the front on rotating.

cool app.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

Tuesday, February 27, 2007 4:17 PM by dwahlin

Yeah...that's a limitation of the current WPF/E release unfortunately.  There's no way to do any type of Z-Index operations without physically changing the order of the Canvas tags that represent the albums in the XAML (something I wasn't willing to spend the time doing since Z-Index would be the easy solution).  I'm hoping they'll add Z-Index in a future release and have made that request to them.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

Wednesday, March 21, 2007 8:40 AM by Peter Kellner

Hi Dan,

Great code!  I'm trying to load your app on a remote server (iis 6, win2003) and it just won't work.  :(

It seems not to get a handle to the canvas's kind of like it never runs the first initialize.  I've run it locally on iis7 and casini and no problems.

I also posted on the wpf/e forums on msdn the same question.

# re: WPF/E and ASP.NET AJAX AlbumViewer Application Now Live (Updated)

Wednesday, March 21, 2007 11:53 AM by dwahlin

Hi Peter,

I'm running the live sample on IIS6 and Windows 2003 as well so I'm not sure what might be giving you problems.  You might want to update the JavaScript file with a few alert messages or something in the load functions to see if those are even being called.  

Also, you'll need to get an Amazon.com developer key and add it into the web.config file.  The Web Service call may be failing since you're on a different domain than mine.  You can get a key for free from the following URL:

https://aws-portal.amazon.com/gp/aws/developer/registration/index.html/103-7399647-0537426?