Compatibility between .NET Framework 1.1 and 2.0 (Beta)

With the release of .NET 2.0 Beta 2, more and more organizations are taking the time to try to port existing .NET 1.X code to 2.0.  From my discussions with numerous developers at Microsoft, I know that backwards compatability was generally a very high priority for them on this release.  Of course, we need to remember that at this point, we are still talking about a BETA version, so it is not at all unreasonable for there to be incompatibilities.  MS is working hard to both document and eliminate these issues - I expect that by RTM, the vast majority of the exusiting incompatabilities will have been corrected and/or clearly documented and explained.

In the meantime, check out these newly published articles on MSDN.  They include a 1.1 to 2.0 Compatability White Paper, Testing Scenarios, and a current List of Breaking Changes:

http://msdn.microsoft.com/netframework/default.aspx?pull=/library/en-us/dnnetdep/html/netfxcompat.asp

http://msdn.microsoft.com/netframework/default.aspx?pull=/library/en-us/dnnetdep/html/NETFXcompatapptest.asp

http://msdn.microsoft.com/netframework/default.aspx?pull=/library/en-us/dnnetdep/html/listofbreakingchanges.asp

 

 

Published Monday, May 30, 2005 10:32 AM by Jackie Goldstein
Filed under: ,

Comments

No Comments