in

ASP.NET Weblogs

Li Chen's Blog

I was asked to install .net framework 3.5 even though I already have it on my machine

Today, when I try to install a Click Once application, I was asked to install .net framework 3.5 even though I already have it on my machine. It turns out that the web application relies on the User-Agent header to determine if I have .net framework 3.5. However, IE9 no longer sends feature token as part of User-Agent. Instead, feature tokens are included in the value returned by the userAgent property of the navigator object. The work around? Just set the IE9 to IE8 compatibility mode and the website is happy.

Published Oct 13 2011, 09:52 PM by dotneteer
Filed under: ,

Comments

No Comments

Leave a Comment

(required)  
(optional)
(required)  
Add