Some more JavaScript Intellisense issues in VS2008

I was experiencing the issues described here where I was getting no colourisation of JavaScript and no Intellisense. I applied the fix mentioned in the post but it didn't work.

Turned out I was missing the file itself file C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\Microsoft.JScript.AuthoringServices.dll and a complete search of the hard drive yielded nothing. Don't know where the file went as Intellisense used to work, but it simply wasn't there.

So I emailed the readify internal techlist and the file was delivered to my inbox shortly thereafter. Once I copied the file to its correct location, everything worked again.

Interestingly, another colleague mentioned that the file did not exist on their system either. I am running VS2008 in a virtual PC but don't know if that had anything to do with it.


  • Yeah, I had the same issue. There's a KB support article on the (I forgot the exact url/KB number). But in nutshell, simply, just reinstall the VS.Net 2008 and that file will be there (somehow from heaven). ;)

  • Sameer,

    Thanks for the response. Now that you mention it, I do remember uninstalling the Silverlight tools for beta 1, which is what removed that DLL. Just copying that file over seemed to fix it though. I dont really want to go through the whole repair/re-install.

    Thanks again.

  • I need to get a hold of this file I don't feel like waiting for the DVD to redownload from MSDN.

    If anyone can provide a link that would be great

Comments have been disabled for this content.