Entity Framework Pitfalls – Migrations Require .NET 4.5

Updated on 28-08: not sure how this problem appeared, but apparently this no longer happens.

If you are to use Entity Framework Code First Migrations, you need to have your project set to use .NET 4.5, before getting the EntityFramework package from NuGet. If you don’t, you will get the .NET 4.0 version, which doesn’t support Migrations out of the box.

image

In order to add this support for .NET 4.0, you need to follow these instructions: http://msdn.microsoft.com/en-us/data/jj618307.aspx.

                             

1 Comment

Comments have been disabled for this content.