Some VS 2010 RC Updates (including patches for Intellisense and Web Designer fixes)

[In addition to blogging, I am also now using Twitter for quick updates and to share links. Follow me at:]

We are continuing to make progress on shipping Visual Studio 2010.  I’d like to say a big thank you to everyone who has downloaded and tried out the VS 2010 Release Candidate, and especially to those who have sent us feedback or reported issues with it. This data has been invaluable in helping us find and fix remaining bugs before we ship the final release.

Last month I blogged about a patch we released for the VS 2010 RC that fixed a bad intellisense crash issue.  This past week we released two additional patches that you can download and apply to the VS 2010 RC to immediately fix two other common issues we’ve seen people run into:

Patch that fixes crashes with Tooltip invocation and when hovering over identifiers

The Visual Studio team recently released a second patch that fixes some crashes we’ve seen when tooltips are displayed – most commonly when hovering over an identifier to view a QuickInfo tooltip.

You can learn more about this issue from this blog post, and download and apply the patch here.

Patch that fixes issues with the Web Forms designer not correctly adding controls to the auto-generated designer files

The Visual Web Developer team recently released a patch that fixes issues where web controls are not correctly added to the .designer.cs file associated with the .aspx file – which means they can’t be programmed against in the code-behind file. 

This issue is most commonly described as “controls are not being recognized in the code-behind” or “editing existing .aspx files regenerates the .aspx.designer.(vb or cs) file and controls are now missing” or “I can’t embed controls within the Ajax Control Toolkit TabContainer or the <asp:createuserwizard> control”.

You can learn more about the issue here, and download the patch that fixes it here.

Common Cause of Intellisense and IDE sluggishness on Windows XP, Vista, Win Server 2003/2008 systems

Over the last few months we’ve occasionally seen reports of people seeing tremendous slowness when typing and using intellisense within VS 2010 despite running on decent machines.  It took us awhile to track down the cause – but we have found that the common culprit seems to be that these machines don’t have the latest versions of the UIA (Windows Automation) component installed.

UIA 3 ships with Windows 7, and is a recommended Windows Update patch on XP and Vista (which is why we didn’t see the problem in our tests – since our machines are patched with all recommended updates).  Many systems (especially on XP) don’t automatically install recommended updates, though, and are running with older versions of UIA. This can cause significant performance slow-downs within the VS 2010 editor when large lists are displayed (for example: with intellisense).

If you are running on Windows XP, Vista, or Windows Server 2003 or 2008 and are seeing any performance issues with the editor or IDE, please install the free UIA 3 update that can be downloaded from this page.  If you scroll down the page you’ll find direct links to versions for each OS.

Note that we are making improvements to the final release of VS 2010 so that we don’t have big perf issues when UIA 3 isn’t installed – and we are also adding a message within the IDE that will warn you if you don’t have UIA 3 installed and accessibility is activated.

Improved Text Rendering with WPF 4 and VS 2010

We recently made some nice changes to WPF 4 which improve the text clarity and text crispness over what was in the VS 2010/.NET 4 Release Candidate.  In particular these changes improve scenarios where you have a dark background with light text.

You can learn more about these improvements in this WPF Team blog post.  These changes will be in the final release of VS 2010 and .NET 4.

Hope this helps,



  • I am getting this error compiling a simple web application. i am Using XP professional version 2002, sp 3. i am now back in vs 2008.

    Error 1 Internal Compiler Error (0xc0000005 at address 3EAC16A1): likely culprit is 'BEGIN'.

    An internal error has occurred in the compiler. To work around this problem, try simplifying or changing the program near the locations listed below. Locations at the top of the list are closer to the point at which the internal error occurred. Errors such as this can be reported to Microsoft by using the /errorreport option.

  • Silverlight 4 Beta pleeeeeeeeeeeeeeeeees

  • Hi Scott,

    When will VS 2010 Final available for MSDN subscribers?


  • can't find 64bit patches... or does it affect x86 systems affected only?

  • When will we be able to use dynamic expressions on custom dataannotations validation attributes?

    Atm only hard coded values like the following can be used:

    I'm unable to dynamically set the max price like so:

    trying to set it dynamically gives a "constant expression required" error.

    Or is there another stratergy to use dynamic values with custom DA validation attributes?


  • I'm getting the same error as Shamol. Seems to occur when trying to compile any solution that includes more than one project.

    Internal Compiler Error (0xc0000005 at address 3EAC16A1): likely culprit is 'BEGIN'

    An un-install / re-install hasn't helped.

  • Any chance of us seeing a patch to fix the problem with not being able to highlight text beyond the visible region of the screen on occasion? The IDE doesn't scroll if you're dragging the cursor, very often. I've tried to post this bug several times and it keeps giving me trouble just trying to login.

  • Now all we need is a patch that makes VS stop holding on to the built DLLs after a debug session.
    Current solution is to shut down VS, delete assemblies and start VS up again. Quite a production killer and you loose undo every time.

  • Great! Now all we need is a patch to prevent VS from holding on to my assemblies after a debug session, preventing me from doing a new build. Current workaround is to shut down VS, manually delete the dll's, and restart VS. A real productivity killer, not to mention annoying to loose my undo history.
    Happens both for my Silverlight and WPF builds.

  • Hi Morten,
    Sorry you are running into some issues with VS 2010 RC. Can you please let us know all the steps involved in reproducing the issue that you are seeing. You can directly send a mail to my work id at:


  • Trying to install UI Automation I'm getting error "The update is not applicable to your computer." Althougn it's correct installer (Server 2008 R2). VS 2010 is thremendously slow on my machine. Please help!

  • Shamol and Dave, can you contact me via email about the crash you are seeing? I'd like to get more info so that I can try to reproduce the behavior. Thanks. --Scott (scottwil at

  • Why not make a RC2 available after Mix with SL4 embedded in it

  • I don't know if this has been addressed by the above but occassionally I find the keyboard no longer works although I can use the mouse and click in different parts of the document. To fix I just switch to another tab and then back again and then the keyboard now works. I've only experience on the odd occasion and it's only been with the RC build not with earlier versions. I haven't filed a bug since I don't have steps to reproduce.

  • ^ Release a RC2 with these fixes and with MVC 2 Final included. That'd be fatnastic.

  • IT could be great if we have a VS2010 RC2 for a month and a half before RTM with SL4,MVC2 and the fixes made available after LAst RC release

  • hi Scott,
    I have sent you a mail. i have attached my project. if you need any further info let me know.

  • depend evaporation small contribute glacial stabilization probably

  • hi Dave,Scott,
    My internal compiler error was cured after i ran this script.
    "C:\Program Files\Microsoft Visual Studio 10.0\Common7\Tools\vsvars32.bat".

  • Scott, why is there no support for snippets in XAML files? HTML, c#, VB, SQL, but no XAML?

  • I wish there were some more service packs for VS2008, specifically to make the WPF designer work, and make editing xaml faster, and stop the "out of memory" errors and random crashes.
    I do love the MS tools, but I'd rather you had longer product cycles and optimised for performance and stability.

  • I've noticed that since I have installed silverlight 4 RC along with my 2010rc i amd getting lots and lots of out of memory errors when compiling ...

    It seems to use over 500megs but seems to run at about 250meg until i open the toolbox .. then the memory usage seems to increase .. after then if i compile it failes

  • @Cameron,

    >>>>>>> I've noticed that since I have installed silverlight 4 RC along with my 2010rc i amd getting lots and lots of out of memory errors when compiling ...

    Can you send me email about this ( I will then connect you with someone who can investigate what is going on.



  • I've experienced something with intellisense that I liked better in VS2008. After typing some letters, I have a yellow outlined selection in intellisense. TAB is the only button inserting the word, though, I'm used to using Enter/Return or Space. Is this just a setting, or are there changes to the behavior?

  • @Anders Ø
    If you pick "Web Developer" as your default settings for the environment, the (Tools/Options/Text Editor/JScript/Miscellaneous) setting for "Only use Tab or Enter to commit" is checked.

  • I have the same problem as Michael described above: some of the keys are not working anymore (like backspace), when tabbing to a different document and then back it appears to work again.

  • I get this error if I start the patcher -.- :
    "KB981167 does not apply, or is blocked by another condition on your computer."

  • Performance is annoying... After 3-4 hours of work with VS on our solution, memory usage goes up to ~700 mb. VS functions start to become slow : Go to Definition, Find All references. Visual studio just hangs for 1-2 minutes. After few tries one of the following happens:
    1) I hear a magic "dong" (windows standard error sound) and visual studio becomes grayed out. But there seems to be no message box .. after that - either it restarts itself after a minute or two, either you have to kill it
    2) "Rain" of message boxes "Operation could not be completed" begins... you close one, another appears ... and so on. Until you kill VS.

    kills productivity ...

    F12 (Go TO definition) sometimes does not work - it goes to correct file, but code lines are somewhere down under - you have to manually scroll to it..

  • I find that 2010 RC is complete junk. How can Mirosoft call this RC. Beta 2 worked far better. So I'm going back to beta 2.

  • Shawn/Adrians - can you send me email ( with more details of the issues you are seeing? I can then connect you with folks who can help investigate.

    Also - can you confirm that you install UIA3 (which I linked to above)? The sluggish typing/scrolling symptoms sound very similar to the problems that happen when it isn't installed.



  • hi, scottgu. the bug i have facing is not a intellisense crash but, not exact intellisense. like in vs2010 when i am coding in .net2 then i get proper intellisense, e.g. me.color = , then only colors will come in intellisense. but when i am coding in .net4, i get the all properties instead of only colors, also sometimes i write something else and it get overwritten by something else from intellisense if common is selected instead of All. any idea some setting or patch that can help me

  • I've had the same keyboard issue as Michael where it won't respond. Usually a restart of VS will fix it. Running on a W7 Pro x64 machine with 8 GB RAM. Sometimes nothing works, other times the regular keys work, but Enter and Esc won't.

Comments have been disabled for this content.