Chris Matts turned me on to the JBehave project (here and here). At first I was skeptical because I didn't see anything different from the xUnit frameworks. However, on contemplating for a moment the fact that I also don't believe that xUnit tests are "Tests" and that I like the "Example" terminology from Brian Marick. The "Behavior" and "Should" terminology start to feel right to me. I'm not sure we need a new project to achieve this. At least with nUnit we can name the methods anything we want, and if you really wanted to you could create new attributes to replace [Fixture] and [Test].
I'll have to try it on my next project or maybe I'll look at a previous one and see if a little judicious renaming makes things clearer.
Another positive result I can envision is to use the behavior/should pattern with new xUnit writers and see if I get better first time "tests".