The Worst Named Operator, Ever
Note: this entry has moved.
Although I try harder and harder to remember of any such misleading operator name used before I can’t find one. Without any doubt, the writers of ECMA-262 (the ECMAScript Language Specification) win the top prize by using the “delete” name for the operator in charge of deleting a property from an object and removing elements from an array.
What exactly were they thinking about when they choose this name?
C’mon guys... you already know there is an operator named delete in other languages with a totally different behavior, don’t you?
remove? removeExpando? removeElement? clearSomething? *Anything* would have been better than delete.